Documentation online

WooCommerce Products Dependencies plugin helps to set product availability depends on many custom rules.

Boost sales on your shop by creating rules for the products:

  • Create must be bought together products
  • Limit minimum selected products number
  • Take prepayment for minimum product quantity with a possibility to order them later

Main features:

  • Category/product/variation dependency with or without checking the quantity
  • Flexible rules with OR / AND conditions
  • Check previous customer’s orders to apply the rule
  • Make any products or categories incompatible for ordering at once
  • Make user must be logged in to buy
  • Minimum product quantity input value
  • Minimum selected products or products quantity from a category per order
  • Possibility to get prepayment for defined product quantity
  • Warnings messages setup

SEE THE DEMO

Changelog

= 2.0.1 =
Fix: Incompatible products setting with the variable products bug
Fix: Variable products dependencies with quantity check
Tweak: Small improvements

= 2.0.0 =
New: "Quantity dependency ratio" setting
New: "Can buy products only once" setting
Tweak: Code refactoring

= 1.17.0 =
New: More settings for product variations
Tweak: Code refactoring

= 1.16.0 =
Fix: Global settings bugs
Tweak: Code refactoring

= 1.15.0 =
New: Products to terms dependencies
New: "Simple auction" plugin support

= 1.14.2 =
Fix: Code fixes

= 1.14.1 =
Fix: "Check customer ordered products" setting bug

= 1.14.0 =
New: Max orders per period option

= 1.13.0 =
New: "Product visibility by users" option
New: Improvement of the "minimum" options
Tweak: Admin styles improvements

= 1.12.2 =
Fix: Dependency min quantity bug

= 1.12.1 =
Fix: Dependency min quantity bug

= 1.12.0 =
New: Prepayment products bundle option
Fix: Minimum total products quantity per order setting bug
Fix: Category quantity dependency bug

= 1.11.0 =
New: Minimum products selected per category option
New: Incompatible categories and products option
Fix: The advance messages bugs

= 1.10.0 =
New: Min product quantity per dependency rule option
Fix: A few dependencies bugs

= 1.9.0 =
New: Better OR/AND dependencies flexibility
New: Custom message option
New: Documentation update

= 1.8.1 =
Fix: Message doubling bug

= 1.8.0 =
New: An advance message about dependencies
Tweak: Code refactoring
Fix: PHP old versions bug
Fix: Logged dependency bug

= 1.7.0 =
New: Quantity dependencies

= 1.6.2 =
Fix: Variation dependencies work

= 1.6.1 =
Removed: Product variation quantity fields in an admin panel

= 1.6.0 =
New: Term minimum products quantity

= 1.5.0 =
New: Product minimum quantity

= 1.4.0 =
New: Product variations dependencies support

= 1.3.5 =
Tweak: Code refactoring

= 1.3.4 =
Fix: Wrong init the front hooks

= 1.3.3 =
Tweak: Code refactoring

= 1.3.2 =
Fix: WooCommerce v3 bugs

= 1.3.1 =
Fix: Admin dependencies fields bugs
New: Admin sortable lists

= 1.3.0 =
New: WooCommerce v3 support
Tweak: Code refactoring

= 1.2.0 =
New: Check product was ordered by the customer earlier

= 1.1.0 =
New: "Logged in" dependency option
Tweak: Code refactoring

= 1.0.2 =
Tweak: jQuery v3 support

= 1.0.1 =
Fix: Check dependencies after set cart item quantity equals zero
Fix: Force removes the item from the cart if found unmet dependency

= 1.0.0 =
Initial release